♥♥ 2021 NEW RECOMMEND ♥♥
Free VCE & PDF File for Red Hat RH302 Real Exam (Full Version!)
★ Pass on Your First TRY ★ 100% Money Back Guarantee ★ Realistic Practice Exam Questions
Free Instant Download NEW RH302 Exam Dumps (PDF & VCE):
Available on:
http://www.surepassexam.com/RH302-exam-dumps.html
Q41. CORRECT TEXT
Configure to allow the pop3 and imap connection from your domain example.com
and my133t.org domain.
Answer and Explanation:
1. vi /etc/hosts.deny
dovecot:ALL EXCEPT .example.com, .my133t.org
We can secure the services using tcp_wrappers. There are main two files, /etc/hosts.allow and /etc/hosts.deny.
There will be three stage access checking
- Is access explicitly permitted? Means permitted from /etc/hosts.allow?
- Otherwise, Is access explicitly denied? Means denied from /etc/hosts.deny?
- Otherwise, by default permit access if neither condition matched.
To deny the services we can configure /etc/hosts.deny file using ALL and EXCEPT operation.
Pattern of /etc/hosts.allow and /etc/hosts.deny file is:
Demon_list:client_list:options
In Client list can be either domain name or IP address.
Q42. CORRECT TEXT
One User named peter working with you as your assistance. His main responsibility is to manager users. Give the privilege to run useradd, passwd, groupadd, userdel, groupdel, usermod command using sudo.
Answer and Explanation:
1. visudo
# User alias Specification
User_alias LIMITEDTRUST=peter
# Cmnd alias Specification
Cmnd_alias MINIMUM=/usr/sbin/useradd, /usr/bin/passwd, /usr/sbin/groupadd, /usr/sbin/userdel,
/usr/sbin/groupdel, /usr/sbin/usermod
# User Privilege Specification
LIMITEDTRUST ALL=MINIMUM
2. Login as peter user and run sudo useradd username
Using Sudo we can give root level privilege on commands. Visudo is the sudo editor. In user alias Specification we create the user alias and in Cmnd alias Specification, we create the command alias. In User Privilege Specification section, list the users, groups allowed to use the sudo.
Q43. CORRECT TEXT
You are giving RHCE exam. You should boot the system in Run level 3. When you start the system after while it is going on runlevel 6 : like
INIT: Entering Run level 6
Sending TERM Single
Fix the problem and boot the system.
Answer and Explanation:
It is due to either default runlevel or runlevel specific scripts.
3. id:?:initdefault: àWhere default runlevel is specified. It shouldn't be 6.
4. l3:3:wait:/etc/rc.d/rc 6 àIt reads the scripts of runlevel 6 while booting system on rulevel 3.
It should be like:
si::sysinit:/etc/rc.d/rc.sysinit
l0:0:wait:/etc/rc.d/rc 0
l1:1:wait:/etc/rc.d/rc 1
l2:2:wait:/etc/rc.d/rc 2
l3:3:wait:/etc/rc.d/rc 3 Should be like this
l4:4:wait:/etc/rc.d/rc 4
l5:5:wait:/etc/rc.d/rc 5
l6:6:wait:/etc/rc.d/rc 6
Q44. CORRECT TEXT
Boot your System Successfully on runlevel 3.
Answer and Explanation:
This is boot related problem. There will be same questions repeated two times but problem is different.
First When you restart the system you will get the Error:
File Not Found
mount: error 15 mounting ext3
mount: error 2 mounting none
switchroot: mount failed: 22
umount /initrd/dev/: 2
Kernel Panic: no syncing: Attempted to kill init !
This error occurred in your system before showing welcome redhat linux. That means problem in grub boot loader.
Restart the System
Check the grub boot loader configuration by pressing e shortcut key.
You will see like:
root (hd0,0)
kernel /vmlinuz-2.6.9-5.EL ro root= / rhgb quiet
initrd /initrd-2.6.9-5.EL.img
OR
root (hd0,0)
kernel /vmlinuz-2.6.9-5.EL ro root=LABEL=/root rhgb quiet
initrd /initrd-2.6.9-5.EL.img
Then Edit Boot loader to make like
root (hd0,0)
kernel /vmlinuz-2.6.9-5.EL ro root=LABEL=/ rhgb quiet
initrd /initrd-2.6.9-5.EL.img
Check all lines and edit as same as above. Press b to boot the system
After booting the system you should correct the /etc/grub.conf file.
If still you are getting Error like File not found, it seems that either kernel file or initrd file is missing.
To troubleshoot with these problem, boot the system on rescue mode.
v. linux rescue
vi. chroot /mnt/sysimage
vii. Check the files on /boot, if not available install the kernel package from ftp or nfs server
viii. Create the initrd image file on boot using: mkinitrd initrd-2.6.9-5.EL.img `uname -r`
Q45. CORRECT TEXT
One Logical Volume named /dev/test0/testvolume1 is created. The initial Size of that disk is 100MB now you required more 200MB. Increase the size of Logical Volume, size should be increase on online.
Answer and Explanation:
1. lvextend -L+200M /dev/test0/testvolume1
Use lvdisplay /dev/test0/testvolume1)
2. ext2online -d /dev/test0/testvolume1
lvextend command is used the increase the size of Logical Volume. Other command lvresize command also here to resize. And to bring increased size on online we use the ext2online command.
Q46. CORRECT TEXT
Change the Group Owner of /data to training group.
Answer and Explanation:
chown or chgrp command is used to change the ownership.
Syntax of chown: chown [-R] username:groupname file/directory
Syntax of chgrp: chgrp [-R] groupname file/directory
Whenever user creates the file or directory, the owner of that file/directory automatically will be that user and that user's primary group name.
To change group owner ship
1. chgrp training /data à Which set the Group Ownership to training
or
chown root.training /data àWhich set the user owner to root and group owner to training group.
Verify /data using: ls -ld /data
You will get: drwxr-xr-x 2 root training ..............
Q47. CORRECT TEXT
/storage directory on linux server should make available on windows system that jeff user should able to access on read only mode within example.com domain.
Answer and Explanation:
1. vi /etc/samba/smb.conf
[global]
netbios name=station?
workgroup=station?
security=user
smb passwd file=/etc/samba/smbpasswd
encrypt passwords=yes
hosts allow= .example.com
[data]
path=/data
public=no
writable=no
browsable=yes
2. smbpasswd -a jeff
3. service smb start
4. chkconfig smb on
/etc/samba/smb.conf. There are some pre-defined section, i. global à use to define the global options, ii. Printers à use to share the printers, iii. homes à use the share the user's home directory.
Security=user à validation by samba username and password. May be there are other users also.
To allow certain share to certain user we should use valid users option.
smbpasswd à Helps to change user's smb password. -a option specifies that the username following should be added to the local smbpasswd file.
Q48. CORRECT TEXT
Add a new logical partition having size 100MB and create the /data which will be the mount point for the new partition.
Answer and Explanation:
Use fdisk /dev/hda à To create new partition.Type n à For New
partitionsIt will ask for Logical or Primary Partitions. Press l for logical.It will ask for the Starting
Cylinder: Use the Default by pressing Enter Key.Type the Size: +100M à You can Specify either
Last cylinder of Size here.Press P to verify the partitions lists and remember the partitions
name.Press w to write on partitions table.Either Reboot or use partprobe command.Use mkfs -t
ext3 /dev/hda?Ormke2fs -j /dev/hda? à To create ext3 filesystem.vi /etc/fstabWrite:/dev/hda? /data
ext3 defaults 0 0Verify by mounting on current Sessions also:mount /dev/hda? /data
Q49. CORRECT TEXT
If root sends the mail to jane, mail should be send to /var/spool/mail/jane.
Answer and Explanation:
By default all mails to user will send to user's spool directory. Nothing to do.
Q50. CORRECT TEXT
Allow the NFS service only to example.com, trusted.cracker.org
Answer and Explanation:
1. vi /etc/hosts.deny
nfs,portmap:ALL EXCEPT .example.com, trusted.cracker.org
We can secure the services using tcp_wrappers. There are main two files, /etc/hosts.allow and /etc/hosts.deny.
There will be three stage access checking
-Is access explicitly permitted? Means permitted from /etc/hosts.allow?
- Otherwise, Is access explicitly denied? Means denied from /etc/hosts.deny?
- Otherwise, by default permit access if neither condition matched.
To deny the services we can configure /etc/hosts.deny file using ALL and EXCEPT operation.
Pattern of /etc/hosts.allow and /etc/hosts.deny file is:
Demon_list:client_list:options
In Client list can be either domain name or IP address.