Cause all that matters here is passing exam with az-500 Dumps Questions. Cause all that you need is a high score of az-500 Dumps Questions. The only one thing you need to do is downloading az-500 Dumps free now. We will not let you down with our money-back guarantee.

Online az-500 free questions and answers of New Version:

NEW QUESTION 1
HOTSPOT
You have an Azure Container Registry named Registry1.
You add role assignment for Registry1 as shown in the following table.
AZ-500 dumps exhibit
Which users can upload images to Registry1 and download images from Registry1? To answer, select the appropriate options in the answer area.
NOTE: Each correct selection is worth one point.
Hot Area:
AZ-500 dumps exhibit

    Answer:

    Explanation: Box 1: User1 and User4 only
    Owner, Contributor and AcrPush can push images.
    Box 2: User1, User2, and User4
    All, except AcrImagineSigner, can download/pull images.
    AZ-500 dumps exhibit
    References:
    https://docs.microsoft.com/bs-latn-ba/azure/container-registry/container-registry-roles

    NEW QUESTION 2
    Note: This question is part of a series of questions that present the same scenario. Each question in the series contains a unique solution that might meet the stated goals. Some question sets might have more than one correct solution, while others might not have a correct solution.
    After you answer a question in this section, you will NOT be able to return to it. As a result, these questions will not appear in the review screen.
    You have an Azure Subscription named Sub1.
    You have an Azure Storage account named Sa1 in a resource group named RG1.
    Users and applications access the blob service and the file service in Sa1 by using several shared access signatures (SASs) and stored access policies. You discover that unauthorized users accessed both the file service and the blob service.
    You need to revoke all access to Sa1. Solution: You generate new SASs. Does this meet the goal?

    • A. Yes
    • B. No

    Answer: B

    Explanation: Instead you should create a new stored access policy.
    To revoke a stored access policy, you can either delete it, or rename it by changing the signed identifier. Changing the signed identifier breaks the associations between any existing signatures and the stored access policy. Deleting or renaming the stored access policy immediately affects all of the shared access signatures associated with it.
    References:
    https://docs.microsoft.com/en-us/rest/api/storageservices/Establishing-a-Stored-Access-Policy

    NEW QUESTION 3
    You have a hybrid configuration of Azure Active Directory (Azure AD).
    All users have computers that run Windows 10 and are hybrid Azure AD joined.
    You have an Azure SQL database that is configured to support Azure AD authentication.
    Database developers must connect to the SQL database by using Microsoft SQL Server Management Studio (SSMS) and authenticate by using their on-premises Active Directory account.
    You need to tell the developers which authentication method to use to connect to the SQL database from SSMS. The solution must minimize authentication prompts.
    Which authentication method should you instruct the developers to use?

    • A. SQL Login
    • B. Active Directory – Universal with MFA support
    • C. Active Directory – Integrated
    • D. Active Directory – Password

    Answer: C

    Explanation: Azure AD can be the initial Azure AD managed domain. Azure AD can also be an on-premises Active Directory Domain Services that is federated with the Azure AD.
    Using an Azure AD identity to connect using SSMS or SSDT
    The following procedures show you how to connect to a SQL database with an Azure AD identity using SQL Server Management Studio or SQL Server Database Tools.
    Active Directory integrated authentication
    Use this method if you are logged in to Windows using your Azure Active Directory credentials from a federated domain.
    1. Start Management Studio or Data Tools and in the Connect to Server (or Connect to Database Engine) dialog box, in the Authentication box, select Active Directory - Integrated. No password is needed or can be entered because your existing credentials will be presented for the connection.
    AZ-500 dumps exhibit
    2. Select the Options button, and on the Connection Properties page, in the Connect to database box, type the name of the user database you want to connect to. (The AD domain name or tenant ID” option is only supported for Universal with MFA connection options, otherwise it is greyed out.)
    References:
    https://github.com/MicrosoftDocs/azure-docs/blob/master/articles/sql-database/sql-database-aad-authentication-configure.md

    NEW QUESTION 4
    HOTSPOT
    You suspect that users are attempting to sign in to resources to which they have no access.
    You need to create an Azure Log Analytics query to identify failed user sign-in attempts from the last three days. The results must only show users who had more than five failed sign-in attempts.
    How should you configure the query? To answer, select the appropriate options in the answer area.
    NOTE: Each correct selection is worth one point.
    Hot Area:
    AZ-500 dumps exhibit

      Answer:

      Explanation: The following example identifies user accounts that failed to log in more than five times in the last day, and when they last attempted to log in. let timeframe = 1d;
      SecurityEvent
      | where TimeGenerated > ago(1d)
      | where AccountType == 'User' and EventID == 4625 // 4625 - failed log in
      | summarize failed_login_attempts=count(), latest_failed_login=arg_max(TimeGenerated, Account) by Account
      | where failed_login_attempts > 5
      | project-away Account1
      References:
      https://docs.microsoft.com/en-us/azure/azure-monitor/log-query/examples

      NEW QUESTION 5
      HOTSPOT
      You have two Azure virtual machines in the East US2 region as shown in the following table.
      AZ-500 dumps exhibit
      You deploy and configure an Azure Key vault.
      You need to ensure that you can enable Azure Disk Encryption on VM1 and VM2.
      What should you modify on each virtual machine? To answer, select the appropriate options in the answer area.
      NOTE: Each correct selection is worth one point.
      Hot Area:
      AZ-500 dumps exhibit

        Answer:

        Explanation: VM1: The Tier
        The Tier needs to be upgraded to standard.
        Disk Encryption for Windows and Linux IaaS VMs is in General Availability in all Azure public regions and Azure Government regions for Standard VMs and VMs with Azure Premium Storage.
        VM2: The type
        Need to change the VMtype to any of A, D, DS, G, GS, F, and so on, series IaaS VMs.
        Not the operating system version: Ubuntu 16.04 is supported. References:
        https://docs.microsoft.com/en-us/azure/security/azure-security-disk-encryption-overview
        https://docs.microsoft.com/en-us/azure/security/azure-security-disk-encryption-faq#bkmk_LinuxOSSupport

        NEW QUESTION 6
        HOTSPOT
        You have an Azure subscription that contains the virtual machines shown in the following table.
        AZ-500 dumps exhibit
        You create the Azure policies shown in the following table.
        AZ-500 dumps exhibit
        You create the resource locks shown in the following table.
        AZ-500 dumps exhibit
        For each of the following statements, select Yes if the statement is true. Otherwise, select No.
        NOTE: Each correct selection is worth one point.
        Hot Area:
        AZ-500 dumps exhibit

          Answer:

          Explanation: AZ-500 dumps exhibit

          References:
          https://docs.microsoft.com/en-us/azure/governance/blueprints/concepts/resource-locking

          NEW QUESTION 7
          From the Azure portal, you are configuring an Azure policy.
          You plan to assign policies that use the DeployIfNotExist, AuditIfNotExist, Append, and Deny effects. Which effect requires a managed identity for the assignment?

          • A. AuditIfNotExist
          • B. Append
          • C. DeployIfNotExist
          • D. Deny

          Answer: C

          Explanation: When Azure Policy runs the template in the deployIfNotExists policy definition, it does so using a managed identity.
          References:
          https://docs.microsoft.com/bs-latn-ba/azure/governance/policy/how-to/remediate-resources

          NEW QUESTION 8
          You have an Azure subscription named Sub1.
          In Azure Security Center, you have a security playbook named Play1. Play1 is configured to send an email message to a user named User1. You need to modify Play1 to send email messages to a distribution group named Alerts.
          What should you use to modify Play1?

          • A. Azure DevOps
          • B. Azure Application Insights
          • C. Azure Monitor
          • D. Azure Logic Apps Designer

          Answer: D

          Explanation: You can change an existing playbook in Security Center to add an action, or conditions. To do that you just need to click on the name of the playbook that you want to change, in the Playbooks tab, and Logic App Designer opens up.
          References:
          https://docs.microsoft.com/en-us/azure/security-center/security-center-playbooks

          NEW QUESTION 9
          You have Azure Resource Manager templates that you use to deploy Azure virtual machines.
          You need to disable unused Windows features automatically as instances of the virtual machines are provisioned. What should you use?

          • A. device compliance policies in Microsoft Intune
          • B. Azure Automation State Configuration
          • C. application security groups
          • D. Azure Advisor

          Answer: B

          Explanation: You can use Azure Automation State Configuration to manage Azure VMs (both Classic and Resource Manager), on-premises VMs, Linux machines, AWS VMs, and on-premises physical machines.
          Note: Azure Automation State Configuration provides a DSC pull server similar to the Windows Feature DSC-Service so that target nodes automatically receive configurations, conform to the desired state, and report back on their compliance. The built-in pull server in Azure Automation eliminates the need to set up and
          maintain your own pull server. Azure Automation can target virtual or physical Windows or Linux machines, in the cloud or on-premises.
          References:
          https://docs.microsoft.com/en-us/azure/automation/automation-dsc-getting-started

          NEW QUESTION 10
          Your company has an Azure subscription named Sub1 that is associated to an Azure Active Directory (Azure AD) tenant named contoso.com.
          The company develops an application named App1. App1 is registered in Azure AD.
          You need to ensure that App1 can access secrets in Azure Key Vault on behalf of the application users. What should you configure?

          • A. an application permission without admin consent
          • B. a delegated permission without admin consent
          • C. a delegated permission that requires admin consent
          • D. an application permission that requires admin consent

          Answer: B

          Explanation: Delegated permissions - Your client application needs to access the web API as the signed-in user, but with access limited by the selected permission. This type of permission can be granted by a user unless the permission requires administrator consent.
          Incorrect Answers:
          A, D: Application permissions - Your client application needs to access the web API directly as itself (no user context). This type of permission requires administrator consent and is also not available for public (desktop and mobile) client applications.
          References:
          https://docs.microsoft.com/en-us/azure/active-directory/develop/quickstart-configure-app-access-web-apis

          NEW QUESTION 11
          DRAG DROP
          You create an Azure subscription.
          You need to ensure that you can use Azure Active Directory (Azure AD) Privileged Identity Management (PIM) to secure Azure AD roles.
          Which three actions should you perform in sequence? To answer, move the appropriate actions from the list of actions to the answer area and arrange them in the correct order.
          Select and Place:
          AZ-500 dumps exhibit

            Answer:

            Explanation: Step 1: Consent to PIM
            AZ-500 dumps exhibit
            Step: 2 Verify your identity by using multi-factor authentication (MFA)
            Click Verify my identity to verify your identity with Azure MFA. You'll be asked to pick an account.
            Step 3: Sign up PIM for Azure AD roles
            Once you have enabled PIM for your directory, you'll need to sign up PIM to manage Azure AD roles.
            References:
            https://docs.microsoft.com/en-us/azure/active-directory/privileged-identity-management/pim-getting-started

            NEW QUESTION 12
            HOTSPOT
            You have Azure virtual machines that have Update Management enabled. The virtual machines are configured as shown in the following table.
            AZ-500 dumps exhibit
            You schedule two update deployments named Update1 and Update2. Update1 updates VM3. Update2 updates VM6.
            Which additional virtual machines can be updated by using Update1 and Update2? To answer, select the appropriate options in the answer area.
            NOTE: Each correct selection is worth one point.
            Hot Area:
            AZ-500 dumps exhibit

              Answer:

              Explanation: Update1: VM1 and VM2 only
              VM3: Windows Server 2021 West US RG2
              Update2: VM4 and VM5 only VM6: CentOS 7.5 East US RG1
              For Linux, the machine must have access to an update repository. The update repository can be private or public. References:
              https://docs.microsoft.com/en-us/azure/automation/automation-update-management

              NEW QUESTION 13
              Your company has an Azure subscription named Sub1 that is associated to an Azure Active Directory Azure (Azure AD) tenant named contoso.com.
              The company develops a mobile application named App1. App1 uses the OAuth 2 implicit grant type to acquire Azure AD access tokens. You need to register App1 in Azure AD.
              What information should you obtain from the developer to register the application?

              • A. a redirect URI
              • B. a reply URL
              • C. a key
              • D. an application ID

              Answer: A

              Explanation: For Native Applications you need to provide a Redirect URI, which Azure AD will use to return token responses.
              References:
              https://docs.microsoft.com/en-us/azure/active-directory/develop/v1-protocols-oauth-code

              NEW QUESTION 14
              HOTSPOT
              You have an Azure Active Directory (Azure AD) tenant named contoso.com that contains the users shown in the following table.
              AZ-500 dumps exhibit
              You create and enforce an Azure AD Identity Protection user risk policy that has the following settings:
              AZ-500 dumps exhibitAssignment: Include Group1, Exclude Group2 Conditions: Sign-in risk of Medium and above Access: Allow access, Require password change
              For each of the following statements, select Yes if the statement is true. Otherwise, select No.
              NOTE: Each correct selection is worth one point.
              Hot Area:
              AZ-500 dumps exhibit

                Answer:

                Explanation: Box 1: Yes
                User1 is member of Group1. Sign in from unfamiliar location is risk level Medium.
                Box 2: Yes
                User2 is member of Group1. Sign in from anonymous IP address is risk level Medium.
                Box 3: No
                Sign-ins from IP addresses with suspicious activity is low.
                Note:
                AZ-500 dumps exhibit
                AZ-500 dumps exhibitAzure AD Identity protection can detect six types of suspicious sign-in activities: Users with leaked credentials
                AZ-500 dumps exhibitSign-ins from anonymous IP addresses Impossible travel to atypical locations Sign-ins from infected devices
                AZ-500 dumps exhibitSign-ins from IP addresses with suspicious activity Sign-ins from unfamiliar locations
                These six types of events are categorized in to 3 levels of risks – High, Medium & Low: References:
                http://www.rebeladmin.com/2021/09/step-step-guide-configure-risk-based-azure-conditional-access-policies/

                NEW QUESTION 15
                HOTSPOT
                You need to create Role1 to meet the platform protection requirements.
                How should you complete the role definition of Role1? To answer, select the appropriate options in the answer area.
                NOTE: Each correct selection is worth one point.
                Hot Area:
                AZ-500 dumps exhibit

                  Answer:

                  Explanation: Scenario: A new custom RBAC role named Role1 must be used to delegate the administration of the managed disks in Resource Group1. Role1 must be available only for Resource Group1.
                  Azure RBAC template managed disks "Microsoft.Storage/" References:
                  https://blogs.msdn.microsoft.com/azureedu/2021/02/11/new-managed-disk-storage-option-for-your-azure-vms/

                  NEW QUESTION 16
                  You need to ensure that User2 can implement PIM.
                  What should you do first?

                  • A. Assign User2 the Global administrator role.
                  • B. Configure authentication methods for contoso.com.
                  • C. Configure the identity secure score for contoso.com.
                  • D. Enable multi-factor authentication (MFA) for User2.

                  Answer: A

                  Explanation: To start using PIM in your directory, you must first enable PIM.
                  1. Sign in to the Azure portal as a Global Administrator of your directory.
                  You must be a Global Administrator with an organizational account (for example, @yourdomain.com), not a Microsoft account (for example, @outlook.com), to enable PIM for a directory.
                  Scenario: Technical requirements include: Enable Azure AD Privileged Identity Management (PIM) for contoso.com References:
                  https://docs.microsoft.com/bs-latn-ba/azure/active-directory/privileged-identity-management/pim-getting-started

                  NEW QUESTION 17
                  HOTSPOT
                  You plan to use Azure Log Analytics to collect logs from 200 servers that run Windows Server 2021.
                  You need to automate the deployment of the Microsoft Monitoring Agent to all the servers by using an Azure Resource Manager template. How should you complete the template? To answer, select the appropriate options in the answer area.
                  NOTE: Each correct selection is worth one point.
                  Hot Area:
                  AZ-500 dumps exhibit

                    Answer:

                    Explanation: AZ-500 dumps exhibit

                    References:
                    https://blogs.technet.microsoft.com/manageabilityguys/2015/11/19/enabling-the-microsoft-monitoring-agent-in-windows-json-templates/

                    NEW QUESTION 18
                    HOTSPOT
                    You have an Azure Active Directory (Azure AD) tenant named contoso.com. The tenant contains the users shown in the following table.
                    AZ-500 dumps exhibit
                    You configure an access review named Review1 as shown in the following exhibit.
                    AZ-500 dumps exhibit
                    Use the drop-down menus to select the answer choice that completes each statement based on the information presented in the graphic.
                    NOTE: Each correct selection is worth one point.
                    Hot Area:
                    AZ-500 dumps exhibit

                      Answer:

                      Explanation: Box 1: User3 only
                      Use the Members (self) option to have the users review their own role assignments.
                      Box 2: User3 will receive a confirmation request
                      Use the Should reviewer not respond list to specify what happens for users that are not reviewed by the reviewer within the review period. This setting does not impact users who have been reviewed by the reviewers manually. If the final reviewer's decision is Deny, then the user's access will be removed.
                      No change - Leave user's access unchanged Remove access - Remove user's access Approve access - Approve user's access
                      Take recommendations - Take the system's recommendation on denying or approving the user's continued access
                      References:
                      https://docs.microsoft.com/bs-latn-ba/azure/active-directory/privileged-identity-management/pim-how-to-start-security-review

                      Recommend!! Get the Full az-500 dumps in VCE and PDF From Surepassexam, Welcome to Download: https://www.surepassexam.com/az-500-exam-dumps.html (New 58 Q&As Version)