Want to know Actualtests 300-101 Exam practice test features? Want to lear more about Cisco Implementing Cisco IP Routing certification experience? Study High quality Cisco 300-101 answers to Regenerate 300-101 questions at Actualtests. Gat a success with an absolute guarantee to pass Cisco 300-101 (Implementing Cisco IP Routing) test on your first attempt.

2021 Dec at 300-101 avalon 10:

Q11. Which two actions must you perform to enable and use window scaling on a router? (Choose two.) 

A. Execute the command ip tcp window-size 65536. 

B. Set window scaling to be used on the remote host. 

C. Execute the command ip tcp queuemax. 

D. Set TCP options to "enabled" on the remote host. 

E. Execute the command ip tcp adjust-mss. 

Answer: A,B 

Explanation: 

The TCP Window Scaling feature adds support for the Window Scaling option in RFC 1323,

TCP Extensions for High Performance . A larger window size is recommended to improve TCP performance in network paths with large bandwidth-delay product characteristics that are called Long Fat

Networks (LFNs). 

The TCP Window Scaling enhancement provides that support. The window scaling extension in Cisco IOS software expands the definition of the TCP window to 32 bits and then uses a scale factor to carry this 32-bit value in the 16-bit window field of the TCP header. 

The window size can increase to a scale factor of 14. Typical applications use a scale factor of 3 when deployed in LFNs. 

The TCP Window Scaling feature complies with RFC 1323. The larger scalable window size will allow TCP to perform better over LFNs. 

Use the ip tcp window-size command in global configuration mode to configure the TCP window size. In order for this to work, the remote host must also support this feature and its window size must be increased. 

Reference: http://www.cisco.com/c/en/us/td/docs/ios-xml/ios/ipapp/

configuration/12-4t/iap-12- 4t-book/iap-tcp.html#GUID-BD998AC6-F128-47DD-B5F7-B226546D4B08


Q12. Which PPP authentication method sends authentication information in clear text? 

A. MS CHAP 

B. CDPCP 

C. CHAP 

D. PAP 

Answer:

Explanation: 

PAP authentication involves a two-way handshake where the username and password are

sent across the link in clear text; hence, PAP authentication does not provide any protection against

playback and line sniffing. CHAP authentication, on the other hand, periodically verifies the identity of the

remote node using a three-way handshake. After the PPP link is established, the host sends a "challenge"

message to the remote node. The remote node responds with a value calculated using a one-way hash

function. The host checks the response against its own calculation of the expected hash value. If the

values match, the authentication is acknowledged; otherwise, the connection is terminated. Reference:

http://www.cisco.com/c/en/us/support/docs/wan/point-to-point-protocol-ppp/10241- ppp-callinhostname.

html


Q13. To configure SNMPv3 implementation, a network engineer is using the AuthNoPriv security level. What effect does this action have on the SNMP messages? 

A. They become unauthenticated and unencrypted. 

B. They become authenticated and unencrypted. 

C. They become authenticated and encrypted. 

D. They become unauthenticated and encrypted. 

Answer:

Explanation: 


Q14. A network engineer is trying to modify an existing active NAT configuration on an IOS router by using the following command: 

(config)# no ip nat pool dynamic-nat-pool 192.1.1.20 192.1.1.254 netmask 255.255.255.0 

Upon entering the command on the IOS router, the following message is seen on the console: 

%Dynamic Mapping in Use, Cannot remove message or the %Pool outpool in use, cannot destroy 

What is the least impactful method that the engineer can use to modify the existing IP NAT configuration? 

A. Clear the IP NAT translations using the clear ip nat traffic * " command, then replace the NAT configuration quickly, before any new NAT entries are populated into the translation table due to active NAT traffic. 

B. Clear the IP NAT translations using the clear ip nat translation * " command, then replace the NAT configuration quickly, before any new NAT entries are populated into the translation table due to active NAT traffic. 

C. Clear the IP NAT translations using the reload command on the router, then replace the NAT configuration quickly, before any new NAT entries are populated into the translation table due to active NAT traffic. 

D. Clear the IP NAT translations using the clear ip nat table * " command, then replace the NAT configuration quickly, before any new NAT entries are populated into the translation table due to active NAT traffic. 

Answer:

Explanation: 


Q15. A network engineer is configuring a solution to allow failover of HSRP nodes during maintenance windows, as an alternative to powering down the active router and letting the network respond accordingly. Which action will allow for manual switching of HSRP nodes? 

A. Track the up/down state of a loopback interface and shut down this interface during maintenance. 

B. Adjust the HSRP priority without the use of preemption. 

C. Disable and enable all active interfaces on the active HSRP node. 

D. Enable HSRPv2 under global configuration, which allows for maintenance mode. 

Answer:

Explanation: 

The standby track command allows you to specify another interface on the router for the

HSRP process to monitor in order to alter the HSRP priority for a given group. If the line protocol of the

specified interface goes down, the HSRP priority is reduced. This means that another HSRP router with

higher priority can become the active router if that router has standby preempt enabled. Loopback

interfaces can be tracked, so when this interface is shut down the HSRP priority for that router will be

lowered and the other HSRP router will then become the active one. Reference: http://www.cisco.com/c/

en/us/support/docs/ip/hot-standby-router-protocol- hsrp/13780-6.html


Most up-to-date ccnp route 300-101 foundation learning guide pdf:

Q16. Which PPP authentication method sends authentication information in cleartext? 

A. MS CHAP 

B. CDPCP 

C. CHAP 

D. PAP 

Answer:

Explanation: 


Q17. You have been asked to evaluate how EIGRP is functioning in a customer network. 

Which key chain is being used for authentication of EIGRP adjacency between R4 and R2? 

A. CISCO 

B. EIGRP 

C. key 

D. MD5 

Answer:

Explanation: R4 and R2 configs are as shown below: 

Clearly we see the actual key chain is named CISCO. 


Q18. What does the following access list, which is applied on the external interface FastEthernet 1/0 of the perimeter router, accomplish? 

router(config)#access-list 101 deny ip 10.0.0.0 0.255.255.255 any log 

router (config)#access-list 101 deny ip 192.168.0.0 0.0.255.255 any log 

router (config)#access-list 101 deny ip 172.16.0.0 0.15.255.255 any log 

router (config)#access-list 101 permit ip any any 

router (config)#interface fastEthernet 1/0 

router (config-if)#ip access-group 101 in 

A. It prevents incoming traffic from IP address ranges 10.0.0.0-10.0.0.255, 172.16.0.0-172.31.255.255, 192.168.0.0-192.168.255.255 and logs any intrusion attempts. 

B. It prevents the internal network from being used in spoofed denial of service attacks and logs any exit to the Internet. 

C. It filters incoming traffic from private addresses in order to prevent spoofing and logs any intrusion attempts. 

D. It prevents private internal addresses to be accessed directly from outside. 

Answer:

Explanation: 

The private IP address ranges defined in RFC 1918 are as follows:

10.0.0.0 - 10.255.255.255

172.16.0.0 - 172.31.255.255

192.168.0.0 - 192.168.255.255 

These IP addresses should never be allowed from external networks into a

corporate network as they would only be able to reach the network from the outside via routing problems or

if the IP addresses were spoofed. This ACL is used to prevent all packets with a spoofed reserved private

source IP address to enter the network. The log keyword also enables logging of this intrusion attempt.


Q19. CORRECT TEXT 

You are a network engineer with ROUTE.com, a small IT company. They have recently merged two organizations and now need to merge their networks as shown in the topology exhibit. One network is using OSPF as its IGP and the other is using EIGRP as its IGP. R4 has been added to the existing OSPF network to provide the interconnect between the OSPF and EIGRP networks. Two links have been added that will provide redundancy. 

The network requirements state that you must be able to ping and telnet from loopback 101 on R1 to the OPSF domain test address of 172.16.1.100. All traffic must use the shortest path that provides the greatest bandwidth. The redundant paths from the OSPF network to the EIGRP network must be available in case of a link failure. No static or default routing is allowed in either network. 

A previous network engineer has started the merger implementation and has successfully assigned and verified all IP addressing and basic IGP routing. You have been tasked with completing the implementation and ensuring that the network requirements are met. You may not remove or change any of the configuration commands currently on any of the routers. You may add new commands or change default values. 

Answer: First we need to find out 5 parameters (Bandwidth, Delay, Reliability, Load, MTU) of the s0/0/0 interface (the interface of R2 connected to R4) for redistribution: 

R2#show interface s0/0/0 

Write down these 5 parameters, notice that we have to divide the Delay by 10 because the metric unit is in tens of microsecond. For example, we get Bandwidth=1544 Kbit, Delay=20000 us, Reliability=255, Load=1, MTU=1500 bytes then we would redistribute as follows: 

R2#config terminal 

R2(config)# router ospf 1 

R2(config-router)# redistribute eigrp 100 metric-type 1 subnets 

R2(config-router)#exit 

R2(config-router)#router eigrp 100 

R2(config-router)#redistribute ospf 1 metric 1544 2000 255 1 1500 

Note: In fact, these parameters are just used for reference and we can use other parameters with 

no problem. 

If the delay is 20000us then we need to divide it by 10, that is 20000 / 10 = 2000) 

For R3 we use the show interface fa0/0 to get 5 parameters too 

R3#show interface fa0/0 

For example we get Bandwidth=10000 Kbit, Delay=1000 us, Reliability=255, Load=1, MTU=1500 bytes 

R3#config terminal 

R3(config)#router ospf 1 

R3(config-router)#redistribute eigrp 100 metric-type 1 subnets 

R3(config)#exit 

R3(config-router)#router eigrp 100 

R3(config-router)#redistribute ospf 1 metric 10000 100 255 1 1500 

Finally you should try to “show ip route” to see the 172.16.100.1 network (the network behind R4) 

in the routing table of R1 and make a ping from R1 to this network. 

Note: If the link between R2 and R3 is FastEthernet link, we must put the command below under 

EIGRP process to make traffic from R1 to go through R3 (R1 -> R2 -> R3 -> R4), which is better 

than R1 -> R2 -> R4. 

R2(config-router)# distance eigrp 90 105 

This command sets the Administrative Distance of all EIGRP internal routes to 90 and all EIGRP external routes to 105, which is smaller than the Administrative Distance of OSPF (110) -> the link between R2 & R3 will be preferred to the serial link between R2 & R4. Note: The actual OPSF and EIGRP process numbers may change in the actual exam so be sure to use the actual correct values, but the overall solution is the same. 


Q20. Refer to the exhibit. 

A network administrator checks this adjacency table on a router. What is a possible cause for the incomplete marking? 

A. incomplete ARP information 

B. incorrect ACL 

C. dynamic routing protocol failure 

D. serial link congestion 

Answer:

Explanation: 

To display information about the Cisco Express Forwarding adjacency table or the hardware Layer 3-

switching adjacency table, use the show adjacency command.

Reasons for Incomplete Adjacencies

There are two known reasons for an incomplete adjacency:

The router cannot use ARP successfully for the next-hop interface.

After a clear ip arp or a clear adjacency command, the router marks the adjacency as incomplete. Then it

fails to clear the entry.

In an MPLS environment, IP CEF should be enabeled for Label Switching. Interface level command ip

route-cache cef No ARP Entry When CEF cannot locate a valid adjacency for a destination prefix, it punts

the packets to the CPU for ARP resolution and, in turn, for completion of the adjacency.

Reference: http://www.cisco.com/c/en/us/support/docs/ip/express-forwarding-cef/17812-cefincomp.

html#t4